String Split and Join in Python - HackerRank Solution
Problem
In Python, a string can be split on a delimiter.
Example:
>>> a = "this is a string" >>> a = a.split(" ") # a is converted to a list of strings. >>> print a ['this', 'is', 'a', 'string']
Joining a string is simple:
>>> a = "-".join(a) >>> print a this-is-a-string
Task
You are given a string. Split the string on a " " (space) delimiter and join using a - hyphen.
Function Description
Complete the split_and_join function in the editor below.
split_and_join has the following parameters:
- string line: a string of space-separated words
Returns
- string: the resulting string
Input Format
The one line contains a string consisting of space separated words.
Sample Input
this is a string
Sample Output
this-is-a-string
Program
1 2 3 4 5 6 7 8 9 | def split_and_join(line): a = line.split( ) result = "-".join(a) return result if __name__ == '__main__': line = input() result = split_and_join(line) print(result) |